Components

- Organization: Organizational Units, Functions, Roles, Employees, Resources
- Process: Tasks, External Entities, Phis (input and Outputs), Connections, Mediums, Processes, Decisions, and Choices
- Attributes: Cost, Time, Place, State

Creating a New Organization File

1. Open IBM Holosofx Workbench. The Organization File dialog box appears.
2. Select the Create A New Organization radio button.
3. Click OK. The New Organization dialog box appears.

Creating a Process

1. Select File > Save Process As with the untitled Process opened. The Process Name dialog box appears.
2. Type "Sales Order Fulfillment" in the Name box.
3. Click OK or press Enter.
Working with the Data Repository

The Repository allows for the storage and management of different types of data tailored to individual Processes, independent of Process model construction. It contains data that pertains to the attributes of an Organization. In addition, it contains data that pertains to the attributes of Business Processes. Once a data record (such as a Task with related attributes) has been created in the Repository it becomes available to be used in all Process models within the organization and can be reused as often as needed to define the Process model objects drawn in the IBM Holosofx Workbench diagrams.

Data Repository: Creating External Entities

1. Select Repository > Organization Data > External Entities. The External Entities dialog box appears.
2. Type "Customer" in the Name box. Click the < button next to the Color box to display a palette of predefined colors. Click once on a basic color to select a pre-defined color.
3. Click Add. The "Customer" item will appear in the External Entity list box.

Data Repository: Creating Roles

A Role identifies the type of work that employees who perform tasks in your organization's Process can perform. Multiple employees can have the same role.

1. Select Repository > Organization Data > Roles. The Roles dialog box appears.
2. Type "Order Processing Clerk" in the Name box.
3. Type "500" in the Standard Cost box and then select the cost increment "week." This entry reflects $500 a week.

Data Repository: Functions

A Function represents various management functions performed in your organization. Examples of these Functions are Production, Sales, Marketing, and so forth.

1. Select Repository > Documentation Data > Functions. The Functions dialog box appears.
2. Type "Customer Services" in the Name box.

Data Repository: Creating Organization Units

Organization Units are the building blocks of your organization's structure. Units usually represent departments, divisions, or sections.

1. Select Repository > Organization Data > Organization Units. The Organization Units dialog box appears.
2. Type "Order Processing" in the Name box.

Data Repository: Creating a Working Calendar

A Calendar defines daily work shifts, weekly working/non-working days, and annual holidays of your organization. IBM Holosofx Workbench comes with a standard calendar already installed.

1. Select Repository > Organization Data > Calendars. The Calendar dialog box appears.
2. Type "Corporate Calendar" in the Name box.
3. To define the hours in your workweek, type "7" instead of "8" in the Day (Hours) box and "35" instead of "40" in the Week (Hours) box.
4. Click the "M" square of the rectangular calendar to select Mondays.
5. Type "9:00" as the starting time instead of "8:00" in the Working Hours.
**External Entity**

- External Entities model either individuals or organizations outside the company that interacts with your Process.

**External Process**

- The External Process is the activity that is performed by an outside organization within your Process.

**External Entity Attributes**

- This is available only for External Process Objects.
- The Start Option specifies additional conditions for the start of the External Process.
- Elapsed Duration is the total length of working time the External Process requires.

**Adding An External Entity To Your Process**

1. Click the External tool button on the ADF Toolbar.
2. Click inside a cell on the grid to insert an External Process/Entity Object inside that cell.
3. Select the Pointer tool button, either by clicking the Pointer tool button on the ADF Toolbar, or by right-clicking anywhere on the diagram.
5. Select the Entity radio button. Select "Customer" from the External Entity list.

**Phis**

- Phis model input/output objects to activities in a Process Model. A Task may or may not transform a Phi during the performance of the task.

**Phis : General Attributes**

- This attribute defines whether one or more activities can process the Phi simultaneously.
- This is a check box to specify if the Phi will be a copy that will be tracked through the Process separately from the original Phi.
- A Phi Type is a class or a group of Phis sharing a common factor.
- There are three (3) Phi Type categories: Paper Document, Electronic Document, and Other. Phi Types are assigned a category.
**Phis: State Attributes**

A Phi can be assigned different states, but can hold only one state at a time at any location in the diagram. For example, you can define the states of a document to be Approved, Not Approved, or Pending. Defining Phi States aids in modeling the status quo of the Phi and in analyzing its life cycle through the Process.

**Partner Interactions**

Partner Interactions can be considered to be Phis of a very specific purpose. They represent electronic data that is transferred between one company and another for the purpose of a business transaction.

**Tasks**

A Task is the lowest level of work in the Process Modeling of IBM Holosofx Workbench. If you do not want to break down an activity into a lower-level of detail, then model that activity as a Task.

If you do want to break down an activity into a lower-level of detail, then model that activity as a Process.

**Adding “Phone Order” Phi**

1. Click the Phi tool button to draw a Phi object.
2. Click inside the cell to the right of the “Customer” object to insert a Phi Object inside that cell.
3. Select the Pointer tool. Double-click the Phi Object you have just inserted. The Phi Object dialog box appears.
4. Type “Phone Order” in the Phi list.
5. Click Phi Type button.
6. Type “Phone Call” in the Name box, then click Ok.
7. In the The Phi Object dialog box, select Type as “Phone Call”. Click Ok to finish.
8. Click the Connector tool button to connect the two objects in your diagram.
9. Click and drag from the center of the “Customer” External Entity object to the center of the “Phone Order” Phi object.

**Partner Interactions Attributes**

This attribute defines the expected number of transactions between business partners for a given period of time.

This attribute defines the amount of time you would expect the Receiving Partner to respond to the message—if a response is required. When the Time Out has been exceeded, the message can be sent again the number of times as specified in the Times to Retry attribute.

This attribute defines the number of times the transaction will be sent to the receiving Partner if the Time Out is exceeded.

If a partner interaction is not available in the combo boxes, create it by clicking here.

**Task: General Attributes**

An Organization Unit can be assigned as being responsible for the Task. This assignment can be used to determine the time and costs associated with the Process for each Organization Unit that participates.

A Role is assigned as being responsible for performing the Task.

A Function represents various management functions performed in your organization. Examples of these Functions are Production, Sales, Marketing, and so forth.

An Application can be assigned as being utilized for the performance of the Task (eg. Word processing).

Elapsed Duration is the total length of working time that the Task takes from the time the Task begins to when it actually ends. A Task begins when the Phi(s) arrive and the Start Option is satisfied. A Task ends when the Phi(s) leave.

Working Duration is the total length of time that the Resources actually spend performing the Task.

The Start Option specifies additional conditions for the start of the Task.

The Calendar assigned to a Task defines the Working Hours during which a Task can be completed IF a Role, Function, Application, Org. Unit, or Calendar is not available in the corresponding combo boxes, you can create new ones by clicking these buttons.
“Enter Order Information” Task

1. Click the Task tool button on the ADF Toolbar.
2. Click inside the cell to the right of the "Phone Order" Phi object to insert a Task Object inside that cell.
3. Select the Pointer tool.
4. Double-click the Task Object you have just inserted. The Task Object dialog box appears.
5. Enter "Enter Customer Order" in the Task Name list.
6. Select "Order Processing" from the Organization Unit list.
7. Select "Order Processing Clerk" from the Role list.
8. Select "Customer Services" in the Function combo box.
9. Type "20" in the Elapsed Duration text box and then select "Minutes".
10. Type "10" in the Working Duration text box and then select "Minutes".
11. Click the Classification tab at the top of the Task Object dialog box.
12. Click the Real Value Added radio button to set the Value-Added.
13. Click the Not Quality Control radio button to set the Quality Control.
14. Click the Potential Workflow radio button to set the Workflow.
15. Click OK or press Enter. The Task Object will be defined.
16. After you have modeled the "Enter Order Information" Task, make a connection from the "Phone Order" Phi to the Task.

Decisions and Choices

- A Decision is a situation with multiple Choices.
- During the Process, you may encounter situations that result in conditions that influence the routing of work. A selection must be made in these situations to define the subsequent Tasks (for example, the question, "Is a review required?") requires a Decision). If a review is required, review Tasks should be performed. Otherwise, no review Tasks need to be considered.
- The Decision can have many outcomes, which are called Choices. The Choice determines which path the Process takes. Choices have a probability attribute that is used to calculate the full probability of a given path through the Process.

Decision Types

- A Binary Decision does not use Choice Objects. The position of the exit point of the two (and only two) Connectors determines the Choice. The "Yes" Choice exits from the right point of the Decision diamond. The "No" Choice exits from the bottom point of the Decision diamond. These Connectors lead to the next object in the Process (not a Choice Object).

- Multiple Decisions use Choice Objects to model the two or more Choices that are part of the Decision. All Connectors exit from the right point of the Decision diamond and lead to a Choice Object. The next objects in the Process are connected from the Choice Objects.

Decision Attributes

- Binary Decision
- Multiple Decision
**Follow**

**Choice Attributes**

- A Defined Decision Object must be connected to the Choice Object before the Choice Object dialog box will open.

**Choice Attributes**

- A Defined Decision Object must be connected to the Choice Object before the Choice Object dialog box will open.

---

**"Type of Order?" Decision**

1. Click the Decision tool button on the ADF Toolbar.
2. Click inside the grid cell to the right of the "Enter Customer Order" Task. A Decision object will be inserted inside that cell.
3. Select the Pointer tool.
4. Double-click the Decision object. The Decision Object dialog box appears.
5. Select the Multiple Radio Button.
6. Type "Type of Order?" in the Decision list.
7. Click OK.
8. Connect the "Enter Customer Order" Task to the "Type of Order?" Decision.

---

**"Choices "Rejected, Off Shelf, or Assembled Product"**

1. Click the Decision Choice tool button on the ADF Toolbar.
2. Click inside the grid cell to the right of the "Type of Order?". A Decision Choice object will be inserted inside that cell.
3. Add two more Decision Choice objects, one above and one below of the cell in Step 2.
4. Select the Connector tool.
5. Make connections from the "Type of Order?" to these three Decision Choice objects.
7. Double-click the Decision objects to edit them. Your model should look like as follows.

---

**Connectors**

- Connectors are used to model both the sequence in which activities occur and the Medium by which a Phi progresses from one activity to the next. When a Connector Object is defined in a diagram, it can be connected with information from the Media category in your Repository and can identify Transfer Time that may be associated with the Phi transfer from one activity to the next. Certain rules must be followed when drawing a Connector. Because a Connector represents the forward progression in the Process Diagram, a Connector can only be drawn going from left to right.

---

**Connector Attributes**

- Connectors are used to model both the sequence in which activities occur and the Medium by which a Phi progresses from one activity to the next. When a Connector Object is defined in a diagram, it can be connected with information from the Media category in your Repository and can identify Transfer Time that may be associated with the Phi transfer from one activity to the next. Certain rules must be followed when drawing a Connector. Because a Connector represents the forward progression in the Process Diagram, a Connector can only be drawn going from left to right.

---
Connectors that Pass through a Phi

- The main purpose of Connectors is to direct the flow from a source activity to a target activity. Phis can be part of the flow between activities (see the figure below). Because the Phi is placed between two activities, the Connector that represents the flow is divided into two Connector objects. This means that the Connector from source (Task A) to the Phi functions as the same Connector that goes from the Phi to the Target (Task B). If you add a Medium to the first Connector, then that Medium is applied to the second Connector. For analysis purposes, the two (2) Connectors are treated as one (1) Connector.

Connectors that Pass through a Decision

- In some situations, the flow from a source activity is dependent on the circumstances within the Process. That is, there is a decision that needs to be made as to which activity will be the target. Therefore, a Decision object should be placed between the source and possible target activities (see the figure below). There is a separate functioning Connector from the source activity (Task A) to all of the possible target activities (Task B and Task C). The Connector from the source activity to the Decision is not used for capturing Media information. Only the Connector from the Decision Choices to the target activities is used for Media.

Primary and Secondary Connectors

- If the Start/Finish Flag is set to F/S (Finish/Start) or S/S (Start/Start), then the connection affects the start of the target Task and the Connector is defined as a Primary Connector.
- If the Start/Finish Flag is set to F/F (Finish/Finish) or S/F (Start/Finish), then the connection affects the end of the target Task and the Connector is defined as a Secondary Connector. These Connectors are drawn with a dashed line (see the figure below).
- In the Design Flow methodology, Secondary Connectors will be used to identify signals that are necessary for the completion of the activity, rather than the start of the activity.

Process Objects (Within a process)

- A Task is the lowest level of work in the Process Modeling of IBM Holosofx Workbench. If you do not want to break down an activity into a lower-level of detail, then model that activity as a Task in an Activity Decision Flow Diagram. If you do want to break down an activity into a lower-level of detail, then model that activity as a Process in an Activity Decision Flow Diagram.

Process Objects Within a process

- To model a Process Object in an Activity Decision Flow Diagram, it is necessary to draw it, define it, and connect it with one or more input and output Phis. Then you can open the diagram for the Process Object and use the same input and output Phis to start and end the model. IBM Holosofx Workbench will match the Phis at both levels (refer to the section entitled Connecting A Process Object in an Activity Decision Flow Diagram). With the matching Phis, IBM Holosofx Workbench can properly insert the lower-level Process into the higher-level Process during Process expansion. In an Activity Decision Flow Diagram, a Process Object is represented by a square (see the figure below).
A Numeric Variable can be assigned to the Process that will define the number of times that the Process should be repeated (how many times it will occur). You can use this variable instead of creating physical copies of the Process in the Process Model.

A Role is assigned as being responsible for overseeing the Process. The responsible Resource can be an employee or software.

An Organization Unit is assigned as being responsible for the Process. Functions represents various management functions performed in your organization. Examples of these Functions are Production, Sales, Marketing, and so forth.

Displays basic statistics that include: Activities, Tasks, Decisions, Process Objects, Phis, External Processes, Organization Units, Resources, etc.; the elapsed duration and working duration of the Process.