Moving to R 3.0.0 on Ubuntu

| 0 Comments | 0 TrackBacks

As you may (or may not) be aware of, R 3.0.0 is scheduled to be released on April 3rd. Since this is a major release and there may be some growing pains (but I hope not) in the move 3.0.0, here is some information about how I will handle R 3.0.0 on CRAN and my PPAs for Ubuntu.

All packages must be rebuilt for R 3.0.0

Any installed packages you are currently using will have to be rebuilt using R 3.0.0. This could lead to some issues, especially is you are using the Ubuntu binaries on CRAN or my PPA. I will try to minimize these issues.

CRAN and RRutter PPA are now frozen to R 2.15.3 (with one exception)

Since many users would probably be alarmed to have production machines upgrade to R 3.0.0 without testing to see if any thing breaks, the packages on CRAN and the RRutter PPA will not be updated anymore. This means R is frozen with version 2.15.3 and the packages available will not be updated on CRAN or the RRutter PPA for now.

At some point, likely around May 1st, I will move CRAN and the RRutter PPA to version 3.0.0. This should give users plenty of time to remove those repositories from apt so the upgrades do not occur. I will warn everyone when I am about to do this.

The one exception to this rule will be the forth coming Ubuntu 13.04 (Raring Ringtail). When I add this release to CRAN and the PPA, I will be using R 3.0.0 and packages built against 3.0.0.

R 3.0.0 and recommended packages will be available on RDev PPA

If you do want to upgrade R to 3.0.0, you can use my RDdev PPA. This will have the latest version of R and the recommended packages built against it. Instructions on how to install the PPA are available at the RDdev PPA webpage. As of right now, only 12.10 (quantal) builds are available, but others will be added when bugs are worked out. Please, do not have the RDev PPA and (CRAN or RRutter PPA) enabled at the same time, as that could cause issues.

What about c2d4u?

Excellent question.

Stopping support for Hardy and Oneiric

Both Hardy (8.04) and Oneiric (11.10) are ending support in April 2013. Therefore, I will not be updating any version of R for these releases. I, for one, am happy to finally be able to rid myself of the albatross (or should I say heron) that is Hardy. I will not delete these files for a while, but there will be no further updates. Support for Lucid (10.04) will continue until April 2015 or until something becomes very broken.

Are you sure you don't have anything to say about c2d4u?

c2d4u is an ambitious project that houses over 1000 packages for R as Ubuntu binaries that can be installed via apt or synaptic. You should really check it out. It has great packages like RCpp and ggplot2, among others.

My first priority will be is to build all the packages for Ubuntu 13.04 (Raring Ringtail) using R 3.0.0. After that is complete, I will start rebuilding the packages for 12.04 (Precise), the latest LTS, against 3.0.0. If I still have any patience left, I will convert the 12.10 (Quantal) packages over.

If you have any questions, please email me. My contact information can be found above.

No TrackBacks

TrackBack URL: https://blogs.psu.edu/mt4/mt-tb.cgi/419664

Leave a comment

Subscribe to receive notifications of follow up comments via email.
We are processing your request. If you don't see any confirmation within 30 seconds, please reload your page.

Search This Blog

Full Text  Tag

Recent Entries

R 3.0.0 and Raring Ringtail (Ubuntu 13.04)
New .deb packages for R 3.0.0 on Raring Ringtail (13.04) are available on both CRAN and my Launchpad PPA. Some…
Moving to R 3.0.0 on Ubuntu
As you may (or may not) be aware of, R 3.0.0 is scheduled to be released on April 3rd. Since…
R 2.15.3 .deb packages now available for Ubuntu
The latest version of R (2.15.3) is now available for Ubuntu. You can find the packages on CRAN or via…