NACIS Presentations on Terrain 
Inspire Penn State Course on 
“Applied Cartographic Design”

Cynthia A. Brewer
Jason McGilloway
Stephen J. Butzler

Gould Center
Geography
Penn State

NACIS 2011
Madison WI

Jay
Steve
Terrain at NACIS 2010

Inspired by talks by:
Leland Brown
Bernhard Jenny
Pat Kennelly
Tom Patterson
Steve Tyson
Alex Tait
Martin Gamache

Also Jim Mower at AutoCarto 2010
Welcome to Penn State Cartography!

Over the Spring 2011 semester, Dr. Cindy Brewer’s Applied Cartographic Design class undertook individualized assignments in developing means of terrain representation. Using methods within ESRI's ArcInfo (ArcGIS 9.3.1), Adobe CS5, and applications developed by Dr. Jenny Bernhard. Compiled lab instruction sets available on this site have been updated for ArcGIS version 10. Additional resources can be found on Esri’s Mapping Center.

This site has been developed by undergraduate intern’s at Penn State’s Gould Mapping Center for cartographic innovations, providing mapping resources, and student internship involvement.

An additional thanks goes to: Tom Patterson, Alex Tait, Pat Kenelly, Bernhard Jenny, Keith Clarke, Reginald Archer, J. Mower, & Leland Brown for their efforts in helping students from GEOG 467.
Gould Mapping Center for cartographic innovations, providing mapping resources, and student internship involvement.

An additional thanks goes to: Tom Patterson, Alex Tait, Pat Kenelly, Bernhard Jenny, Keith Clarke, Reginald Archer, J. Mower, & Leland Brown for their efforts in helping students from GEOG 467.

Lab 1: By Rick Fourroux. Basic functions of Arc and Photoshop.
ArcGIS 10: ArcGIS Basics.pdf

Lab 2: By Cory Helm. Overlaying feature data in Photoshop
ArcGIS 10: Feature Data.pdf

Lab 3: By Ethan Jackson. 3D Terrain representation methods
ArcGIS 10: Inclined Plane.pdf

Lab 4: By Kase Hartog. Basic Photoshop filters.
Photoshop Filters.pdf

Lab 5: By Jason McGilloway. Jenny's applications in Arc.
ArcGIS 10: Jenny Apps.pdf

Lab 6: By Sarah Layton & Alex Tait. Advanced Photoshop methods
AdvancedPhotoshop.pdf

Lab 7: Nicholas Maziekas. Illuminated contours
ArcGIS 10:Texture.pdf

Lab 8: By Claire Steiner. Sky Model rendering with hillshades
ArcGIS 10: Sky Models.pdf

Lab 9: By Tim Haynes. Advanced Terrain representation
ArcGIS 10:Advanced Terrain.pdf

Lab 10: By Joe Ritzman. Generating flow lines.
ArcGIS 10: Flow Lines.pdf

Lab 11: By Kevin Sparks. Scree Painter.
ArcGIS 10:Scree.pdf

Lab 12: By Andy Stauffer. Realism with Bump Mapping
ArcGIS 10:Realism.pdf

ArcGIS 10:Texture.pdf

Lab 14: By Bo Yao. J. Mower's Block Diagrams
Creating ESRI Hillshades, Lighting in CS4/CS5, Clipping & Merging DEMs, Projections

This lab focuses on basic functions of ArcGIS Version 10.1 and Adobe CS4/CS5 software packages run on a Windows 7 platform. External data for this lab will be downloaded from www.pasda.psu.edu. This lab contains 4 major sections (A, B, C, & D)

A. Projections

Most data from 3rd party sources are normally in GCS which are un-projected, which if performing statistical operations are best if re-projected in UTM or SPC. This can be accomplished by either setting the spatial reference of the file or creating projected copy.

For setting spatial reference navigate to DEM in Arc Catalog, Right click file and scroll to properties. In Raster Dataset Properties scroll down to Spatial Reference, click Edit. For predefined projections click Select and choose Projected Coordinate Systems. Choose either UTM or SPC and select which zone DEM falls into. Go back to ArcMap, right click Layers > Properties > Coordinate System and choose appropriate reference.

For re-projecting/projection DEM’s in ArcMap, Open ArcToolbox > Data Management Tools > Projections and Transformations > Raster > Project Raster. (This function can also be found in the search window by typing "project raster"). Set the Resampling Technique to Cubic.
Lab 3: Fishnet Plots and Traces of Inclined Planes
(Ethan Jackson Lead)

B.3 Creating Inclined DEM Raster from TIN

This section prepares the raster dataset we will use to derive our inclined plane contours.

- ArcToolBox > 3D Analyst Tools > From TIN > TIN to Raster.
- Output location must be within the Geodatabase!

The next step calculates the final raster set needed
- Spatial Analyst > Map Algebra > Raster Calculator
- Use the Raster from the TIN + the original DEM
Exploring Filters in Photoshop

This lab has been created for the use of Adobe CS4/CS5 Photoshop for exemplifying current terrain sets already created in ArcGIS. An important note for this lab, the use of Photoshop filters is destructive editing, therefore be sure to make a copy of the original terrain set in CS5. Do this by right clicking the layer in LAYERS and select Duplicate Layer.

The filters used in this lab can also be applied to the entire map or just certain areas selected using the Rectangular Marquee Tool, the Lasso Tool, and Quick Selection tool located in the tool bar on the left side of the screen. Additionally, after selecting a specific area press CNTRL + D to de-select current features.

### Water

1) Make a duplicate layer of your map before fiddling with any filters.
2) Use the “Quick Select Tool” and drag your mouse around the dark blue area that represents deep water in the upper right-hand corner of the map to highlight it.
3) From the filters Menu > Artistic > Plastic Wrap (take a few minutes to play with the rest of the artistic filters).
Lab 5: Terrain Sculptor from Bernhard Jenny et al. (Jay McGilloway Lead)

ArcGIS Hillshade

Terrain Sculptor generalization
ArcGIS Hillshade

Open DEM in Arc
ArcToolbox > Conversion Tools > From Raster > Raster to ASCII.
This creates a .txt file, open in Windows Notepad
Set "NoDATA_value" to 0
Convert "Cellsize" from DD to Meters
DD Value (if not projected in UTM) / 180 * Pi * 6371000.
X,Y coordinate refer to the DEM's bottom left corner, if this DEM is in a projected coordinate system then these values are fine. Otherwise just delete. Save .txt file

Open SAGA-GIS. Modules Libraries > Import/Export-GDAL/OGR > GDAL: Import Raster
Navigate to the .txt file you previous modified by selecting "..." > Ok
Module Libraries > Import/Export-Grids > Export ESRI Arc/Info Grid
Choose .txt file from drop down menus in Data Objects, set name and save destination in File. Close SAGA-GIS

B. Terrain Sculptor

Open folder > Terrainsculptor > Select Run on security window > Navigate to your ASCII file previously created.

Advanced settings tab enables exaggeration of high and low land based on features.
Lab 6: Non-Destructive Multipliers in Photoshop from Alex Tait (Sarah Layton Lead)

By Andy Stauffer

By Sarah Layton
Lab 6: Non-Destructive Multipliers in Photoshop

- Now click on the **Masks Tab** and click **Invert**. You should notice that the dark and light values have been inverted.
- You should now see the hillshade appears in the mask. The dark blue is restricted to the shaded slopes. *This is because the grayscale mask values determine the opacity of the adjustment layer throughout the image.* The inverted black slopes do not let any color through on the illuminated side of the terrain.
- Now, *choke the mask* by going to **Image → Adjustments → Levels**
- Push the black slider to the middle, and the white slider in. This brightens the whites and darkens the rest by restricting the range of dark values.
- Back under the **Layers tab**, change the blending mode to **Multiply** for a more realistic appearance.
- Set the **Opacity** of the layer to 40%
Lab 7: Illuminated Contours (Nick Maziekas Lead)

By Bo Yao

A.2 Reclassify Hill Shade

Going to Spatial Analyst Tools > Reclass > Reclassify. The input raster will be the hill shade generated from the previous step. Select Classify... and enter 18 in the classes section. Choose Equal Interval for the Methods section.
Lab 8: Uniform Sky Illumination from Pat Kennelly (Claire Steiner Lead)

By Ethan Jackson

Three illumination directions

Nine illumination directions

See Kennelly & Stewart CaGIS 2006 article
C. Intensities and Exaggerations of Hill Shade Lighting

In this section we will focus in how the light is distributed between a more complicated lighting model (using 9 point sources of varying altitude/elevation and azimuth or direction. This will offer another tool for visually displaying certain terrain aspects and features.

Referring back to the first diagram in the introduction section of this instruction set are the list of values and how you should perceive these lighting sources in space (based on the introduction).

<table>
<thead>
<tr>
<th>Azimuth</th>
<th>Inclination</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>90</td>
</tr>
<tr>
<td>45</td>
<td>45</td>
</tr>
<tr>
<td>90</td>
<td>0</td>
</tr>
<tr>
<td>135</td>
<td>45</td>
</tr>
<tr>
<td>180</td>
<td>0</td>
</tr>
<tr>
<td>225</td>
<td>45</td>
</tr>
<tr>
<td>270</td>
<td>0</td>
</tr>
<tr>
<td>315</td>
<td>45</td>
</tr>
</tbody>
</table>
A.2 Reclassification

In this section we will reclassify both layers created in sections 1A.1 & 1A.2. Both procedures will use the same directory path ArcToolbox > Spatial Analyst Tools > Reclass > Reclassify. The dialog box which presents itself

We need to reclassify this into four categories based on the high and low values within the DEM. Best way to determine which value break work are open the DEM's histogram
Lab 9: Slope/Aspect Arrows from Pat Kennelly

Open the layers property for the non-illuminated layer > Symbology > Quantities > Graduated Symbols

Set the attribute field that represents slope value in the value category (Note this may be identified as the grid code with the smaller decimal number explained above).

Categorize into 4 classes

In the template section choose a basic ESRI arrow or line symbol
In the Advanced button > Rotation > select the aspect value

Repeat process for the illuminated layer as well.
Lab 10: Curvature and Flow Accumulation (Joe Ritzman Lead)

D. Curvature

To add more realistic effects, go to 3D Analyst Tools in ArcToolBox. Raster Surface > Curvature. Use the DEM as input. This will render a more realistic layer for water flow lines.

Use methods learned from previous labs to overlay the rendered flowline data, curvature, hill shade, and DEM

By Sarah Layton
Lab 11:

D. Importing Data into Scree Painter

There are four pieces of information needed for Scree Painter to work correctly. Upon opening the Scree interface you will need to input all 4 files.

D.1 The Scree Interface

There are many tools to utilize in scree painter, most of them self-explanatory. One to focus on is the Stone Size and Density graph under the density tab at the top left corner. The dark areas of the shaded relief are where the scree is denser and larger. The graph (on the top) adjusts the size and density of the scree. If you drag the line to the upper bounds of the graph fewer stones are placed and the stones are smaller. Experiment with this and other tools to produce an outcome pleasing to you.
Open the bump map tool located in the toolbox added from the initial set up procedures. Below lists a general use guide for parameters:

1. Input Raster: Forest Mask created in the previous step.
2. Cones or Domes: Cones best for wooded areas, Domes for low lying undergrowth
3. Vegetation Density: Lower number = Denser bumping
4. Vegetation Radius: Larger number = larger diameter
5. Vegetation Height: (For Cones only) Larger number = higher height
6. Input Raster: DEM
7. Output Raster Dataset: Name appropriately, default saved to current workspace.

Note: this tool has been derived from a model builder therefore can be in parts or as the entire model. For starters its recommend to choose the Bump Map Model option.

<table>
<thead>
<tr>
<th>Input Raster (Vegetation Mask)</th>
<th>Cones or Domes</th>
<th>Vegetation Density</th>
<th>Vegetation Radius</th>
<th>Vegetation Height</th>
<th>Input Raster (DEM)</th>
<th>Output Raster Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forest Mask</td>
<td>Cones</td>
<td>25</td>
<td>25</td>
<td>50</td>
<td>LeafLFSi demT6.mxd</td>
<td>LeafLFSi.hill.shd</td>
</tr>
</tbody>
</table>

If this tool crashes, double check the ToolData folder by selecting Add Data to your current map document. Add vegplusdem file. Save and Close Arc. Open ArcCatalog and Navigate to the Veg0 file, set the spatial reference to that of the DEM. Open and add Veg0 to ArcMap.

From vegplusdem layer create a hillshade layer
Spatial Analyst Tools > Surface > Hillshade.
Lab 13: Texture Shading with Partial Laplacian Filters from Leland Brown (Evan Klauda Lead)

By Claire Steiner
C. Converting back to Arc
Double check via windows explorer that this file was successfully created and stored in the folder where the texture.exe program is located.

We will now bring this file back into ArcGIS and convert it to a GRID file by going to ArcToolbox > Conversion Tools > To Raster > Floats to Raster. Input the new .flt file rendered in the Texture program as the input and have the output location and name saved appropriately.

C.1 Display in Arc
With any other raster data set you can manipulate the histogram through this layer's Properties > Symbology > Stretched > Histogram. Select the Use Hillshade effect and use a z factor between 3-5 if your hills appear too bright.
The final project

• Two locations
  – One distinct terrain (stratified sampling of country)
  – One common “strip” DEM of Yellowstone terrain

• Two designs – serious and creative
  – Designs combine multiple methods (e.g., elevation tints + curvature + 3 hillshade directions)

• Two scales
Hillshade (NW, no smoothing)

Bump Hillshade (derived from forest mask)

Hillshade from DEM smoothed 30 times (NW)

Elevation tints from dark blue to green to light grey

Black and white orthoimage

Bump mask – light green (colored mask overlaid on forest bumps)

Yellow on northwest aspects and dark grey on southeast

Hydrography vector data

Contour lines – dark blue to green to light grey through elevation
Texture layer with a gain of ½ (30% transparent)
9-direction hillshade composite (weight on NW) (55%)
Elevation gradient from a rich medium green to a light grey
Highlight layer of light green
Slight drop shadow and bevel on hydrography to sink into terrain
**Layer order:**
Curvature (80% transparent)
Aspect - NW yellow around to darker SE (70%)
Composite hillshade - 9 illumination directions, weighted NW, W, W
Elevation tints

Central Nevada, 1:500,000
Railroads, Roads, Waterbodies

Incorporated Place Polygons

NLCD Forest Polygons

Tapered Streams

NLCD Crops Polygons

2/3 Fractional Laplacian Operator (Texture)

3-direction Hillshade

Bump Map Hillshade

2 ft Contours

Plan Curvature

Profile Curvature
Simple transparent hillshade (from ArcMap)

Shadows (blue) and highlights (yellow and white) using choked hillshade as mask (Alex Tait’s Photoshop method)

Texture shading with color ramp, alpha value of 2/3 (Leland Brown’s software)
By Rick Fourroux

Composite of 5 hillshades: directly overhead and SE (higher weight), S, SW, W

Curvature

Elevation tints

Orthoimage

Canyon Lands region of southeast Utah
B. Jenny’s *Terrain Sculptor*
generalized DEM

Curvature

Composite of three hillshade directions

Diffuse glow filter

Mammoth Cave area in Kentucky
In Photoshop:

Yellow highlight (20% opacity) and dark blue shadows created with masks from choking hillshade created from 9 illumination directions (from Arc) with softened valley bottom detail (30%)

Curvature in grayscale (30%)

DEM with a gradient map

Olympia National Park in the Pacific Northwest region
DEM: Remove/smooth major lower elevation features (5x5 focal filter ran 20-30 times); exported to Terrain Sculptor to exaggerate ridges and major valleys

Texture layer, 0.65 to 0.7 exponent value

Standard NW hillshade

Aspect, 8 classes, light-dark

Elevation tints

Vegetation selected from orthoimage

Mt. Mansfield, Vermont
Layer order:
- NHD water
- Contours (45% opacity)
- Hillshade (50%)
- Curvature of DEM (30%)
- Curvature of Hillshade (30%)
- Elevation

Extra operations in Photoshop:
- Water vectors beveled and softened
- Sponge and plastic wrap filters
- Saturation layer and gradient map
- Rendered lighting effects
Roads

Outer Glow on hydrography

Illuminated contours

Orthoimage

9-direction hillshade

Texture shading ½ alpha

Sharpen twice, Paint Daubs filter
Indexed elevation contours
Texture Shading, gain 2/3
Brush, trees and new trees as separate bump maps from NLCD
Grassland, volcanic rock, and ice masks, Bevel and Emboss filters
Choke hillshade masks for shadows, highlights and bright highlights, Bevel and Emboss filters on highlights
Custom-made texture from a picture of gravel for appearance of random heights amongst tree stands
Textured filter on waterbodies

By Tim Haynes
Creative versions

By Tim Haynes
Sky Illumination hillshade - higher weights on illumination from southeast azimuths for inversion

Inclined contours – Instead of the plane set at 45 degrees (standard) it is 315 degrees to follow the inverted terrain

Hydrography vectors with Photoshop effects and filters

By Kevin Sparks
Extra fun with Photoshop

By Nick Maziekas
Thanks!

**Class students:**
Ethan Jackson, Cory Helm, Kase Hartog, Evan Klauda, Jay McGilloway, Sarah Layton, Nick Maziekas, Joe Ritzman, Kevin Sparks, Andy Stauffer, Rick Fourroux, Bo Yao, Claire Steiner, Tim Haynes

**At NACIS 2011:**
Rick Fourroux’s poster and Andy Stauffer’s talk derive from the class

**Project judges:** Charlie Frye & Damien Demaj (Esri), Mike Hermann, Anthony Robinson, Paulo Raposo, Steve Butzler, Alex Savelyev

**Course visitors:** Calvin Meyer, Kristin Fishburn, Helmut Lestinsky, Mike Cooley, Bob Davis (USGS)...

**Guest speakers:** Eric Constance (USGS), Pat Kennelly (Long Island), Alex Tait (IMA)

**Lots of email help:** Jim Mower, Bernhard Jenny, Leland Brown

**Coauthors:**
Steve Butzler did initial testing on all ArcGIS 9.3 labs with students

Jay McGilloway created the Arc10 reformatted lab versions and class web page
Website linked to [www.personal.psu.edu/cab38](http://www.personal.psu.edu/cab38)

13 student labs upgraded to Arc10, or in CS5, with explicit instructions on data processing for individual methods, including:

<table>
<thead>
<tr>
<th>Method</th>
<th>Author(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEM and hillshade basics</td>
<td></td>
</tr>
<tr>
<td>fishnet</td>
<td></td>
</tr>
<tr>
<td>inclined planes</td>
<td></td>
</tr>
<tr>
<td>curvature</td>
<td></td>
</tr>
<tr>
<td>multi-direction hillshades</td>
<td></td>
</tr>
<tr>
<td>aspect and slope</td>
<td></td>
</tr>
<tr>
<td>illuminated contours</td>
<td></td>
</tr>
<tr>
<td>indexed contours</td>
<td></td>
</tr>
<tr>
<td>flow accumulation</td>
<td></td>
</tr>
<tr>
<td>PS filters</td>
<td></td>
</tr>
<tr>
<td>PS choked-mask hillshade (Alex)</td>
<td></td>
</tr>
<tr>
<td>PS non-destructive editing (Alex)</td>
<td></td>
</tr>
<tr>
<td>Terrain Sculptor (Bernie)</td>
<td></td>
</tr>
<tr>
<td>Scree Painter (Bernie)</td>
<td></td>
</tr>
<tr>
<td>Texture shading (Leland)</td>
<td></td>
</tr>
<tr>
<td>hachure arrows (Pat)</td>
<td></td>
</tr>
<tr>
<td>realism (Tom)</td>
<td></td>
</tr>
</tbody>
</table>

DEM(s) or other images not provided—**BYOD**